yaboot prompt options. How to load initrd?

Paul Nasrat pnasrat at googlemail.com
Thu Jan 10 05:59:53 EST 2008

On 09/01/2008, Jose.ALISTE <jose.aliste at gmail.com> wrote:
> Hi,
> My question may be trivial, but I have "googled" a lot and I can't find
> a solution, so I try here.
> I have a non-working kernel and initrd in my ibook configured in my
> yaboot.conf(/boot/vmlinux and /boot/initrd.img). I know that the
> previous initrd and kernel worked and  they are in /boot/vmlinux.old and
> /boot/initrd.img.old in the same partition(/dev/hda3) . At yaboot prompt
> I try to do:
> boot:/boot/vmlinux.old root=/dev/hda3 ro
> but this ends with a  KERNEL panic because I don't load the initrd(it's
> the standard kernel and initrd shipped with ubuntu). I have tried to
> find how to tell yaboot in the prompt about the initrd, But I can't find
> the info. I'm using yaboot 1.3.13 and  I tried adding:
> initrd=/boot/initrd.img.old or initrd /boot/initrd.img.old to the
> previous prompt line but it does not load the initrd.  Is there a way to
> do it? or I definitely have to rescue with a CD?

You can't with yaboot 1.3.13 - HEAD supports this functionality, you
can however, boot yaboot HEAD
(http://people.fedoraproject.org/~pnasrat/yaboot) off a USB key
(format it as FAT 12/16) and  boot using cli or a fixed conf (you can
also load the conf by device (OF device), partition and filename).


More information about the Yaboot-users mailing list