Installing Ubuntu on an XServe

Todd O'Bryan toddobryan at
Thu Jun 7 10:15:26 EST 2007

Thanks for the help. Here's what I can report...

I gave up on using Ubuntu. The version of the partitioner didn't
recognize RAID partitions and the version of yaboot got very confused by
the drives. (It identified them as sda1 and sda2.)

I installed Debian instead, and it worked pretty flawlessly. The
partitioner worked first try (It identified the hard drives as hde and
hdg, strangely enough.) and yaboot had no problems.

Hopefully the problems with the Ubuntu install CD will get fixed, but
since the server lives at an ISP, I don't have the time to sit with it
and get all the debug information that would be needed to help with

Thanks again,

On Wed, 2007-06-06 at 11:15 -0400, David Cantrell wrote:
> On Sat, 2007-06-02 at 10:48 +0100, Paul Nasrat wrote:
> > On Fri, 2007-06-01 at 20:48 -0400, Todd O'Bryan wrote:
> > > Another wrinkle that I should mention is that the version of parted
> > > included with the Ubuntu install CD (I've tried using both alternate and
> > > server versions) seems to have some problems. I could never get it to
> > > set up the drives as a software RAID array and today, after dropping
> > > into the shell and trying to run parted manually, I got a message saying
> > > "You've found a bug in parted" which was promptly followed by a core
> > > dump.
> > 
> > David - any ideas on the parted issue.  What version of parted is it you
> > are using?
> Definitely need more information about how you were using parted.  You
> can't use parted to set up a software RAID device.  You use parted to
> partition an already set up software RAID device though.
> parted --version will display the version number of parted.
> Please include the commands you used which led to the parted bug.
> Thanks,

More information about the Yaboot-users mailing list