[Skiboot] [OpenPower-Firmware] How to flash openPOWER on a Habanero system (8348-21C)

Klaus Heinrich Kiwi klaus at linux.vnet.ibm.com
Sat Feb 6 04:25:08 AEDT 2021

Hi Nick?

On 2/5/2021 9:22 AM, Nick Singer wrote:

> I didn't consider it as
> https://github.com/open-power/op-build/issues/848#issuecomment-276980698
> states that the HPM format is not build by op-build. The second option I
> have in the BMC is "AMI" which seems to be proprietary and signed. At
> least when I tried to upload my pnor file it complained about unsigned code.
>>> What skiboot version are you using? There was a fix on 5.4.0 that
>>> could be related:
>>> https://github.com/open-power/skiboot/issues/44
>>> (it might mean you need to pair the pflash utility with the skiboot
>>> version
>>> you are currently using)
> After you mentioning this I tried several versions of pflash. Starting
> from a very old release (early 5.x, as I couldn't build 4.x) up to the
> latest release and even tried master. Some of the older versions
> couldn't even retrieve the information (./pflash -i) while the later
> where perfectly able to do this. Also reading out the pnor works
> flawlessly (I took a "backup" with pflash as well as with dd from
> /dev/mtd0).
So I don't think you mentioned what skiboot version you are using..

There was another issue that was fixed with 5.11:

And I suspect that the issue affects skiboot, not pflash.

If that's the case, you might be forced to go the BMC route to do
an out-of-band update.


Klaus Heinrich Kiwi <klaus at linux.vnet.ibm.com>

More information about the Skiboot mailing list