[Skiboot] [PATCH v2] opal-api: Reserve 2 OPAL API calls for future OpenCAPI LPC use
Andrew Donnellan
andrew.donnellan at au1.ibm.com
Mon Apr 1 15:44:28 AEDT 2019
On 20/3/19 5:38 pm, Stewart Smith wrote:
> Andrew Donnellan <andrew.donnellan at au1.ibm.com> writes:
>> OpenCAPI Lowest Point of Coherency (LPC) memory is going to require
>> some extra OPAL calls to set up NPU BARs. These calls will most likely be
>> called OPAL_NPU_LPC_ALLOC and OPAL_NPU_LPC_RELEASE, we're not quite ready
>> to upstream that code yet though.
>>
>> Reserve 171 and 172 for this purpose.
>>
>> Signed-off-by: Andrew Donnellan <andrew.donnellan at au1.ibm.com>
>
> We're probably going to want to name it something other than LPC to
> avoid confusion with the LPC bus for some poor soul knee deep in
> something terrible.
>
> Maybe if we refer to it as LPoC when the abbreviation is used?
Can we get this merged perhaps with a note that I'll pick a better name
not involving "LPC"? I'm thinking "OPAL_NPU_OCAPI_MEM_{ALLOC,RELEASE}"
at the moment.
>
>> The LPC allocator code is coming once I get a chance to work on it
>> again after finishing my current OpenCAPI work. We have a trivial allocator
>> that we've been using internally for testing, and Alastair wants to start
>> getting the kernel side of this ready.
>
>> ---
>> include/opal-api.h | 4 +++-
>> 1 file changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/include/opal-api.h b/include/opal-api.h
>> index 73f86f9a5ccf..acf05746f01f 100644
>> --- a/include/opal-api.h
>> +++ b/include/opal-api.h
>> @@ -226,7 +226,9 @@
>> #define OPAL_NX_COPROC_INIT 167
>> #define OPAL_NPU_SET_RELAXED_ORDER 168
>> #define OPAL_NPU_GET_RELAXED_ORDER 169
>> -#define OPAL_LAST 169
>> +#define OPAL_NPU_RESERVED1 170 /* LPC Allocate */
>> +#define OPAL_NPU_RESERVED2 171 /* LPC Release */
>> +#define OPAL_LAST 171
>>
>> #define QUIESCE_HOLD 1 /* Spin all calls at entry */
>> #define QUIESCE_REJECT 2 /* Fail all calls with OPAL_BUSY */
>> --
>> 2.11.0
>>
>> _______________________________________________
>> Skiboot mailing list
>> Skiboot at lists.ozlabs.org
>> https://lists.ozlabs.org/listinfo/skiboot
>>
>
--
Andrew Donnellan OzLabs, ADL Canberra
andrew.donnellan at au1.ibm.com IBM Australia Limited
More information about the Skiboot
mailing list