[Skiboot] [PATCH v2 00/23] POWER9 DD2 series

Stewart Smith stewart at linux.vnet.ibm.com
Mon Jun 26 17:09:56 AEST 2017


Michael Neuling <mikey at neuling.org> writes:
> This is a resend and ACK.  These are working well for me.
>
> Ack-by: Michael Neuling <mikey at neuling.org>
>
> v2 fixes:
>   - patch 9&10/24 bisecting problem on patch by merging them
>   - patch 21/24 (now 20/23) Fixed issue with old binutils (hence Travis CI).
>
> Benjamin Herrenschmidt (21):
>   xive: DD2.0 updates
>   phb4: DD2.0 updates
>   phb4: Workaround bug in spec 053
>   phb3/4: Move IO VPD preload out to a common place
>   phb3/4: Silence a useless warning
>   hdat/vpd: Don't warn and don't create a dummy "model-name"
>   psi: Use phys_map to setup the BARs
>   lpc: Enable "new" SerIRQ mode
>   psi: Switch to ESB mode later
>   xive: Remove historical BAR reading code
>   libffs: Fix ffs_lookup_part() return value
>   cpu: Add a space to #threads message
>   flash: Silence some messages
>   init: Silence messages and call ourselves "OPAL"
>   Big log level reduction...
>   Move cleanup_tlb from head.S to misc.S
>   Rename cleanup_tlb() to cleanup_local_tlb()
>   Add "cleanup_global_tlb" for P9 and later
>   cpu: Make init_hid() local to cpu.c
>   cpu: Rework HILE change
>   cpu: Support setting HID[RADIX] and set it by default on P9
>
> Russell Currey (2):
>   phb4: Properly mask out link down errors during reset
>   phb4: Mask out write-1-to-clear registers in RC cfg
>
>  asm/head.S          |  13 --
>  asm/misc.S          |  73 +++++++++
>  core/cpu.c          | 119 ++++++++++----
>  core/device.c       |   2 +-
>  core/fast-reboot.c  |   7 +-
>  core/flash.c        |   8 +-
>  core/init.c         |  28 ++--
>  core/interrupts.c   |   4 +-
>  core/mem_region.c   |   2 +-
>  core/nvram-format.c |   9 +-
>  core/opal.c         |   4 +-
>  core/pci.c          |   2 +-
>  core/vpd.c          |  11 ++
>  hdata/spira.c       |   2 +-
>  hdata/vpd.c         |   3 -
>  hw/lpc.c            |  17 +-
>  hw/phb3.c           |  12 +-
>  hw/phb4.c           | 459 +++++++++++++++++++++++++++++++++++-----------------
>  hw/phys-map.c       |   4 +-
>  hw/psi.c            |  62 +++----
>  hw/slw.c            |   4 +-
>  hw/xive.c           | 147 +++++++----------
>  hw/xscom.c          |  16 +-
>  include/cpu.h       |   5 +-
>  include/opal-api.h  |   9 ++
>  include/phb4-regs.h |  16 +-
>  include/phb4.h      |   2 +-
>  include/phys-map.h  |   2 +-
>  include/processor.h |   1 +
>  include/skiboot.h   |   6 +-
>  include/xive.h      |   7 +
>  libflash/libffs.c   |  10 +-
>  libstb/stb.c        |   4 +-
>  33 files changed, 677 insertions(+), 393 deletions(-)

Thanks! From my look through of v1 and changes here, things look pretty
good, so merged to master as of
1cb276acc130d1dfbd8ce8347d2ee27035178e65.

I'll also push this all up into op-build in a tick.


-- 
Stewart Smith
OPAL Architect, IBM.



More information about the Skiboot mailing list