[Skiboot] [RFC PATCH 1/5] dt: add dt_new_check()
Vasant Hegde
hegdevasant at linux.vnet.ibm.com
Fri Sep 16 18:41:27 AEST 2016
On 09/16/2016 12:14 PM, Oliver O'Halloran wrote:
> This is similar to dt_new(), but if the node already exists it will
> return the existing node. This is useful because some init code depends
> on the presence of certain nodes, but where the node is actually created
> is unimportant.
>
> Signed-off-by: Oliver O'Halloran <oohall at gmail.com>
> ---
> core/device.c | 14 ++++++++++++++
> include/device.h | 1 +
> 2 files changed, 15 insertions(+)
>
> diff --git a/core/device.c b/core/device.c
> index 9e7ef0d448d9..bd0674e31fda 100644
> --- a/core/device.c
> +++ b/core/device.c
> @@ -352,6 +352,20 @@ struct dt_node *dt_find_by_name(struct dt_node *root, const char *name)
> return NULL;
> }
>
> +
> +struct dt_node *dt_new_check(struct dt_node *parent, const char *name)
Patch itself looks good.
Reviewed-by: Vasant Hegde <hegdevasant at linux.vnet.ibm.com>
May be its better to rename function as dt_new_get() ?
Also it doesn't takes care of handling node creation with address etc.. which is
probably fine for now ..as we have issues with node name without address (like
ibm,opal).
-Vasant
More information about the Skiboot
mailing list