[Skiboot] [PATCH V8 4/9] errorlog: Rename 'fsp_log_state' to 'sp_log_state'
Mukesh Ojha
mukesh02 at linux.vnet.ibm.com
Tue Nov 15 21:10:40 AEDT 2016
'fsp_log_state' variable name looks irrelevant when we move the generic
routines to core/errorlog.c. As this variable is valid for any
service processor(SP). So better to rename it as 'sp_logs_state'.
Signed-off-by: Mukesh Ojha <mukesh02 at linux.vnet.ibm.com>
Reviewed-by: Vasant Hegde <hegdevasant at linux.vnet.ibm.com>
---
Changes in V8:
- Previous version V7 1/12 to 3/12 is already in the master.
- Rebased on master.
Changes in V7:
- Subject tag changed from opal/errorlog to errorlog.
Changes in V6:
- Rebased on master.
Changes in V5:
- New patch.
core/errorlog.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/core/errorlog.c b/core/errorlog.c
index 337e21d..da01b58 100644
--- a/core/errorlog.c
+++ b/core/errorlog.c
@@ -234,7 +234,7 @@ void log_simple_error(struct opal_err_info *e_info, const char *fmt, ...)
void elog_set_head_state(bool opal_logs, enum elog_head_state state)
{
static enum elog_head_state opal_logs_state = ELOG_STATE_NONE;
- static enum elog_head_state fsp_logs_state = ELOG_STATE_NONE;
+ static enum elog_head_state sp_logs_state = ELOG_STATE_NONE;
/* ELOG disabled */
if (!elog_enabled)
@@ -243,9 +243,9 @@ void elog_set_head_state(bool opal_logs, enum elog_head_state state)
if (opal_logs)
opal_logs_state = state;
else
- fsp_logs_state = state;
+ sp_logs_state = state;
- if (fsp_logs_state == ELOG_STATE_FETCHED_DATA ||
+ if (sp_logs_state == ELOG_STATE_FETCHED_DATA ||
opal_logs_state == ELOG_STATE_FETCHED_DATA)
opal_update_pending_evt(OPAL_EVENT_ERROR_LOG_AVAIL,
OPAL_EVENT_ERROR_LOG_AVAIL);
--
2.7.4
More information about the Skiboot
mailing list