[Skiboot] [PATCH v2 2/5] slw: Change variable name can_winkle to has_slw

Shreyas B. Prabhu shreyas at linux.vnet.ibm.com
Tue May 3 16:57:05 AEST 2016


Change variable name "can_winkle" to a more generic name "has_slw". This
makes it easier to add new deep-idle states which rely on SLW.

Signed-off-by: Shreyas B. Prabhu <shreyas at linux.vnet.ibm.com>
---
 hw/slw.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/hw/slw.c b/hw/slw.c
index 231fefcd0b58..68b61ea80ccd 100644
--- a/hw/slw.c
+++ b/hw/slw.c
@@ -497,7 +497,8 @@ void add_cpu_idle_state_properties(void)
 	struct proc_chip *chip;
 	int nr_states;
 
-	bool can_sleep = true, can_winkle = true;
+	bool can_sleep = true;
+	bool has_slw = true;
 	u8 i;
 
 	u32 supported_states_mask;
@@ -569,8 +570,8 @@ void add_cpu_idle_state_properties(void)
 		nr_states = ARRAY_SIZE(power7_cpu_idle_states);
 	}
 
-	/* Enable winkle only if slw image is intact */
-	can_winkle = (chip->slw_base && chip->slw_bar_size &&
+	/* Enable deep idle states only if slw image is intact */
+	has_slw = (chip->slw_base && chip->slw_bar_size &&
 			chip->slw_image_size);
 
 	/*
@@ -600,7 +601,7 @@ void add_cpu_idle_state_properties(void)
 	if (can_sleep)
 		supported_states_mask |= OPAL_PM_SLEEP_ENABLED |
 					OPAL_PM_SLEEP_ENABLED_ER1;
-	if (can_winkle)
+	if (has_slw)
 		supported_states_mask |= OPAL_PM_WINKLE_ENABLED;
 
 	for (i = 0; i < nr_states; i++) {
-- 
1.9.3



More information about the Skiboot mailing list