[Skiboot] [PATCH 1/2] libflash/libffs: Rename ffs_cmp() to ffs_equal()

Stewart Smith stewart at linux.vnet.ibm.com
Tue Jan 12 16:57:22 AEDT 2016

Cyril Bur <cyril.bur at au1.ibm.com> writes:
> Some confusion has arisen from the first consumer of ffs_cmp() in that they
> expected a strcmp style less than one, zero or greater than one return value.
> This has been addressed in this patch in two ways, by changing the return
> type to a boolean in order to (attempt) to alert the programmer that this
> is not the case and by renaming it to equal to avoid the implied comparison
> and imply very much a boolean outcome.
> Signed-off-by: Cyril Bur <cyril.bur at au1.ibm.com>
> ---
>  libflash/libffs.c | 2 +-
>  libflash/libffs.h | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)

If I was a better person, I'd have said this before merging it
originally - so I'll go sit in the corner looking stupid for a
while. It's okay, the Corner has coffee[1]

Series merged as of 1663987
(assuming this didn't need to go to stable)

[1] while in Melbourne, The Corner Hotel has live music and beer!

Stewart Smith
OPAL Architect, IBM.

More information about the Skiboot mailing list