[Skiboot] [PATCH V4 1/6] fsp: Add CAPP lid definition for Naples

Philippe Bergheaud felix at linux.vnet.ibm.com
Fri Apr 1 23:27:56 AEDT 2016


Signed-off-by: Philippe Bergheaud <felix at linux.vnet.ibm.com>
---
V2, V3: No changes
V4:
  - s/CAPP_IDX_NAPLES_DD21/CAPP_IDX_NAPLES_DD10/

 hw/fsp/fsp.c | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/hw/fsp/fsp.c b/hw/fsp/fsp.c
index 26ae71e..888da88 100644
--- a/hw/fsp/fsp.c
+++ b/hw/fsp/fsp.c
@@ -2260,6 +2260,7 @@ int fsp_fetch_data_queue(uint8_t flags, uint16_t id, uint32_t sub_id,
 #define CAPP_IDX_VENICE_DD20 0x200ea
 #define CAPP_IDX_MURANO_DD20 0x200ef
 #define CAPP_IDX_MURANO_DD21 0x201ef
+#define CAPP_IDX_NAPLES_DD10 0x100d3
 
 static struct {
 	enum resource_id	id;
@@ -2272,6 +2273,7 @@ static struct {
 	{ RESOURCE_ID_CAPP,	CAPP_IDX_MURANO_DD21,	0x80a02001 },
 	{ RESOURCE_ID_CAPP,	CAPP_IDX_VENICE_DD10,	0x80a02003 },
 	{ RESOURCE_ID_CAPP,	CAPP_IDX_VENICE_DD20,	0x80a02004 },
+	{ RESOURCE_ID_CAPP,	CAPP_IDX_NAPLES_DD10,	0x80a02005 },
 };
 
 static void fsp_start_fetching_next_lid(void);
-- 
2.1.0



More information about the Skiboot mailing list