[Skiboot] [v2, 1/3] powerpc/powernv: convert codes returned by OPAL calls

Benjamin Herrenschmidt benh at kernel.crashing.org
Fri Mar 27 21:36:27 AEDT 2015

On Fri, 2015-03-27 at 20:59 +1100, Michael Ellerman wrote:
> Can you put it in opal.h and give it a better name, maybe
> opal_error_code() ?

Do we want it to be inlined all the time ? Feels more like something we
should have in opal.c

Also we only want to call it when we "forward" the error code up the
food chain, there are a number of cases where we look for specific OPAL
error codes.


More information about the Skiboot mailing list