[Skiboot] [PATCH v2 5/5] external/opal-prd: Add 'run' option to execute HBRT commands

Daniel M Crowell dcrowell at us.ibm.com
Tue Aug 25 13:39:40 AEST 2015

I don't like mfg_ as a prefix for this one because it likely would have 
nothing to do with manufacturing.  I would suggest some kind of --debug 
flag but that is already in use.  Maybe "opdev_" for Open Power Developer? 

Dan Crowell
Senior Software Engineer - Power Systems Enablement Firmware
IBM Rochester: t/l 553-2987
dcrowell at us.ibm.com

From:   Patrick Williams <patrick at stwcx.xyz>
To:     Neelesh Gupta <neelegup at linux.vnet.ibm.com>
Cc:     skiboot at lists.ozlabs.org, Daniel M Crowell/Rochester/IBM at IBMUS, 
Bill Schwartz/Austin/IBM at IBMUS, Christopher J Cain/Rochester/IBM at IBMUS
Date:   08/24/2015 05:02 PM
Subject:        Re: [Skiboot] [PATCH v2 5/5] external/opal-prd: Add 'run' 
option to execute HBRT commands

On Tue, Aug 25, 2015 at 12:50:37AM +0530, Neelesh Gupta wrote:
> From: Vaidyanathan Srinivasan <svaidy at linux.vnet.ibm.com>
> opal-prd client to accept run command and pass it as-is to hbrt.
> Example:
> opal-prd -d run test hbrt -t 1 -c "good cmd"
> argv[0] = test
> argv[1] = hbrt
> argv[2] = -t
> argv[3] = 1
> argv[4] = -c
> argv[5] = good cmd
> Above argc/argv passed to hbrt->run_command() and result out string
> sent to the console.

Is this one suppose to be a 'manufacturing' command as well?  I don't
believe our intention is to use this for any permanent code.  This
should be one of those "only use if you know what you are doing"

We may want to change the name of the Hostboot side to 'mfg_run_command'
if we determine this is a 'manufacturing' command.

Patrick Williams
[attachment "signature.asc" deleted by Daniel M Crowell/Rochester/IBM] 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ozlabs.org/pipermail/skiboot/attachments/20150824/c81a19f7/attachment.html>

More information about the Skiboot mailing list