[PATCH v2] docker: update dependency for current build
lukas.bulwahn at gmail.com
Wed Feb 12 14:35:47 AEDT 2020
From: Pranav Annam <pranavannam at gmail.com>
The dependency libssl1.0-dev in the Dockerfile makes docker build fail:
The following packages have unmet dependencies:
libmysqlclient-dev : Depends: libssl-dev (>= 1.1.1-1ubuntu2.1~18.04.5~)
but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
There seems to be a conflict with different versions of libssl and
libmysqlclient that did not exist previously with Ubuntu 18.04.
Just use the current libssl-dev from Ubuntu 18.04 to fix the build.
Signed-off-by: Pranav Annam <pranavannam at gmail.com>
[rephrased commit message]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn at gmail.com>
Pranav, here is my proposal on how future patches should look
like. Please look at the difference to your original patch.
Stephen, Daniel, please pick the patch with the commit message
that you prefer and explain to us why (for future newcomers to
be pointed out to and learn).
tools/docker/Dockerfile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/docker/Dockerfile b/tools/docker/Dockerfile
index 5ef1120..62ac461 100644
@@ -35,7 +35,7 @@ RUN apt-get update && apt-get install -y --no-install-recommends \
- libssl1.0-dev \
+ libssl-dev \
More information about the Patchwork