[PATCH v5 0/7] Add series support

Daniel Axtens dja at axtens.net
Thu Oct 13 10:41:49 AEDT 2016

Daniel Axtens <dja at axtens.net> writes:

>>> - "untitled series #420" is certainly better than having every series 
>>> named
>>> "untitled series", but I still think it's worse than "series starting 
>>> with
>>> '[1/10] add foo to bar'"
>> Should be trivial enough change. I wonder if we should save this into 
>> the db on calculate it on the fly like I do for 'untitled series'? I'll 
>> need to benchmark it and if the former is no slower, then this can be a 
>> follow-up patch. If the latter is more performant, we'll need to respin.
> So this is the only one I'm at all concerned about potentially needing a
> respin.
> You'd have to find the first patch in the series to work it out. I'm a
> bit nervous that would be expensive.
Oh, one potential complexity - do we handle the case where the patches
arrive with correct headers but are received out of order? In that case,
this is a pretty tricky problem.

> Regards,
> Daniel
>>> I don't think all of this stuff would need to be included in the 
>>> initial
>>> implementation, and I think one of us would be able to work on it.  Are 
>>> you
>>> aware of anything here that would be backwards incompatible that might 
>>> need to
>>> go in now?  The only thing I can think of would be the series naming.
>> Yeah, I'm doing all of this in my spare time so it's going to be tough 
>> to address all of the above in one giant series (hence breaking it up). 
>> Personally, I'd like to see us review the series as-is right now, with a 
>> focus on the models and parser, then start building upon it with 
>> follow-up patches. Thoughts?
>> Stephen
>> [1] https://github.com/justquick/django-activity-stream

More information about the Patchwork mailing list