[PATCH net-next v3 03/10] net: pcs: xpcs: Convert xpcs_id to dw_xpcs_desc

Andrew Lunn andrew at lunn.ch
Thu Jun 27 23:10:18 AEST 2024


> -	for (i = 0; i < ARRAY_SIZE(xpcs_id_list); i++) {
> -		const struct xpcs_id *entry = &xpcs_id_list[i];
> +	for (i = 0; i < ARRAY_SIZE(xpcs_desc_list); i++) {
> +		const struct dw_xpcs_desc *entry = &xpcs_desc_list[i];
>  
>  		if ((xpcs_id & entry->mask) != entry->id)
>  			continue;
>  
> -		xpcs->id = entry;
> +		xpcs->desc = entry;

Maybe rename entry to desc here?

Otherwise

Reviewed-by: Andrew Lunn <andrew at lunn.ch>

    Andrew


More information about the openbmc mailing list