Using local git repo for recipe development

Vijay Khemka vijaykhemka at
Fri Oct 30 09:10:16 AEDT 2020

What are you trying to achieve here, devtool is for local source and you 
already have local source, just build it from there.

On 10/29/20, 2:33 PM, "Patrick Voelker" <Patrick_Voelker at> wrote:

    Vijay, that didn't make any difference.  I get the same result.

    > -----Original Message-----
    > From: Vijay Khemka [mailto:vijaykhemka at]
    > Sent: Thursday, October 29, 2020 12:27 PM
    > To: Patrick Voelker; OpenBMC (openbmc at
    > Subject: Re: Using local git repo for recipe development
    > On 10/29/20, 10:17 AM, "openbmc on behalf of Patrick Voelker" <openbmc-
    > at on behalf of
    > Patrick_Voelker at> wrote:
    >     I'm creating a new recipe for local development but when I do a 'devtool
    > modify <recipe>' it always seems to make an empty directory (that contains
    > only .git.)
    >     Here's the relevant lines from my .bb file:
    >     SRC_URI = "git:///home/pvoelker/bmc/dev/oem;protocol=file"
    > I am not too sure but this should be file://, You may have to fix above line.
    >     SRCREV = "4db17f482b0bdcdcf5658c7d323cc563eb78556a"
    >     inherit autotools
    >     Here's the warning from 'devtool modify':
    >     WARNING: No source unpacked to S - either the phoenix-oem recipe
    > doesn't use any source or the correct source directory could not be
    > determined
    >     If I change either the SRC_URI or the SRCREV to be invalid, I get an error
    > instead of a warning so it's definitely finding the local repo.
    >     I can't figure out why none of the files in my commit are making it into the
    > unpack directory.  Any ideas or tips on debugging?  I also tried using  a .tar.gz
    > file instead of a local git repo and had the same result.

More information about the openbmc mailing list