[PATCH] Document Linux's memory barriers [try #4]

Linus Torvalds torvalds at osdl.org
Fri Mar 10 10:56:35 EST 2006

On Fri, 10 Mar 2006, Michael Buesch wrote:
> So what about:
> #define spin_lock_mmio(lock)	spin_lock(lock)
> #define spin_unlock_mmio(lock)	do { spin_unlock(lock); mmiowb(); } while (0)

You need to put the mmiowb() inside the spinlock.

Yes, that is painful. But the point being that if it's outside, then when 
somebody else gets the lock, the previous lock-owners MMIO stores may 
still be in flight, which is what you didn't want in the first place.

Anyway, no need to make a new name for it, since you might as well just 
use the mmiowb() explicitly. At least until this has been shown to be a 
really common pattern (it clearly isn't, right now ;)


More information about the Linuxppc64-dev mailing list