[PATCH]: ppc64: Rename routines to make it clear they're arch-specific.

linas linas at austin.ibm.com
Fri Jan 13 11:08:10 EST 2006


[PATCH]: ppc64: Rename routines to make it clear they're arch-specific.

This patch renames two routines, unmap_bus_range() and remap_bus_range(),
to make it clear that the are associated with the architecture, rather
than being interpreted as generic bus or geeric pci routines.

Signed-off-by: Linas Vepstas <linas at austin.ibm.com>

Index: linux-2.6.15-git8/arch/powerpc/kernel/pci_64.c
===================================================================
--- linux-2.6.15-git8.orig/arch/powerpc/kernel/pci_64.c	2006-01-12 16:21:14.578944328 -0600
+++ linux-2.6.15-git8/arch/powerpc/kernel/pci_64.c	2006-01-12 16:21:29.024919529 -0600
@@ -1173,7 +1173,7 @@
 	return 0;
 }
 
-int unmap_bus_range(struct pci_bus *bus)
+int pcibios_unmap_bus_range(struct pci_bus *bus)
 {
 	unsigned long start_phys;
 	unsigned long start_virt;
@@ -1191,9 +1191,9 @@
 
 	return 0;
 }
-EXPORT_SYMBOL(unmap_bus_range);
+EXPORT_SYMBOL_GPL(pcibios_unmap_bus_range);
 
-int remap_bus_range(struct pci_bus *bus)
+int pcibios_remap_bus_range(struct pci_bus *bus)
 {
 	unsigned long start_phys;
 	unsigned long start_virt;
@@ -1216,14 +1216,14 @@
 
 	return 0;
 }
-EXPORT_SYMBOL(remap_bus_range);
+EXPORT_SYMBOL_GPL(pcibios_remap_bus_range);
 
 void phbs_remap_io(void)
 {
 	struct pci_controller *hose, *tmp;
 
 	list_for_each_entry_safe(hose, tmp, &hose_list, list_node)
-		remap_bus_range(hose->bus);
+		pcibios_remap_bus_range(hose->bus);
 }
 
 static void __devinit fixup_resource(struct resource *res, struct pci_dev *dev)
Index: linux-2.6.15-git8/arch/powerpc/kernel/rtas_pci.c
===================================================================
--- linux-2.6.15-git8.orig/arch/powerpc/kernel/rtas_pci.c	2006-01-12 16:21:14.578944328 -0600
+++ linux-2.6.15-git8/arch/powerpc/kernel/rtas_pci.c	2006-01-12 16:21:29.024919529 -0600
@@ -394,7 +394,7 @@
 		return 1;
 	}
 
-	rc = unmap_bus_range(b);
+	rc = pcibios_unmap_bus_range(b);
 	if (rc) {
 		printk(KERN_ERR "%s: failed to unmap IO on bus %s\n",
 			__FUNCTION__, b->name);
Index: linux-2.6.15-git8/drivers/pci/hotplug/rpadlpar_core.c
===================================================================
--- linux-2.6.15-git8.orig/drivers/pci/hotplug/rpadlpar_core.c	2006-01-12 16:21:25.543407514 -0600
+++ linux-2.6.15-git8/drivers/pci/hotplug/rpadlpar_core.c	2006-01-12 16:21:29.024919529 -0600
@@ -152,7 +152,7 @@
 	pcibios_claim_one_bus(dev->bus);
 
 	/* ioremap() for child bus, which may or may not succeed */
-	remap_bus_range(dev->subordinate);
+	pcibios_remap_bus_range(dev->subordinate);
 
 	/* Add new devices to global lists.  Register in proc, sysfs. */
 	pci_bus_add_devices(phb->bus);
@@ -383,7 +383,7 @@
 		rpaphp_unconfig_pci_adapter(bus);
 	}
 
-	if (unmap_bus_range(bus)) {
+	if (pcibios_unmap_bus_range(bus)) {
 		printk(KERN_ERR "%s: failed to unmap bus range\n",
 			__FUNCTION__);
 		return -ERANGE;
Index: linux-2.6.15-git8/include/asm-powerpc/pci.h
===================================================================
--- linux-2.6.15-git8.orig/include/asm-powerpc/pci.h	2006-01-12 16:21:14.578944328 -0600
+++ linux-2.6.15-git8/include/asm-powerpc/pci.h	2006-01-12 16:21:29.025919389 -0600
@@ -209,9 +209,9 @@
 	return root;
 }
 
-extern int unmap_bus_range(struct pci_bus *bus);
+extern int pcibios_unmap_bus_range(struct pci_bus *bus);
 
-extern int remap_bus_range(struct pci_bus *bus);
+extern int pcibios_remap_bus_range(struct pci_bus *bus);
 
 extern void pcibios_fixup_device_resources(struct pci_dev *dev,
 			struct pci_bus *bus);



More information about the Linuxppc64-dev mailing list