[PATCH 0/8] powerpc: Kexec fixups and support for booting at 32MB

Milton Miller miltonm at bga.com
Tue Nov 15 05:23:06 EST 2005


I do have comments on this series, but have been slow to write them
down.

PS: Please copy me on kexec/kdump ppc patches so I can reply with 
references.  I read the lists from the web.

Quickly:

[PATCH 1/8] powerpc: Turn cpu_irq_down into kexec_cpu_down
(1) I was hoping to share code with cpu dlpar remove
(2) If we need a seperate vpa call fine, but don't put an
interrupt controller compare in a funtion, we may need a seperate
pointer.   Since we won't (are'nt likely to?) have vpa and mpic, I
would settle today for having vpa call xics if it was near the
setup function.

[PATCH 5/8] powerpc: Add CONFIG_CRASH_DUMP
the __va change should be in  [PATCH 4/8] powerpc: Seperate usage of 
KERNELBASE and PAGE_OFFSET

And should this not be last, since following patches are required
to get the kernel to work again?   What, you need PHYISCAL_START
for them?  well just #define it 0 for a bit in patch 4.

[PATCH 6/8] powerpc: Reroute interrupts from 0 + offset to 
PHYSICAL_START + offset

The following should be in user space / device tree:
+#ifdef CONFIG_CRASH_DUMP
+       lmb_reserve(0, KDUMP_BACKUP_LIMIT);
+#endif


[PATCH 7/8] powerpc: Create a trampoline for the fwnmi vectors
I totally disagree with this one, espically reregitering with
the low address in the trampoline.  The registration should be at
the new address.  And a1, a2 are very generic names.

[PATCH 8/8] powerpc: Fixups for kernel linked at 32 MB
(1) powermac smp.c -- use create_branch
(2) The secondary hold code could be done as a 64 bit load in the
first 0x100 bytes vs LOADADDR
(3) Why did you move LOAD_HANDLER down one instruction?  It would
seem not to help optimization

milton




More information about the Linuxppc64-dev mailing list