[PATCH 2/8] make OF node fixup code usable at runtime

Joel Schopp jschopp at austin.ibm.com
Fri Mar 11 06:41:38 EST 2005


Nathan Lynch wrote:

> At boot we recurse through the device tree "fixing up" various fields
> and properties in the device nodes.  Long ago, to support DLPAR and
> hotplug, we largely duplicated some of this fixup code, the main
> difference being that the new code used kmalloc for allocating various
> data structures which are attached to the new device nodes.
> 
> This patch kills most of the duplicated code and makes finish_node,
> finish_node_interrupts, and interpret_pci_props suitable for use at
> runtime.  These functions, if passed a null mem_start argument, will
> use kmalloc for allocating extra data structures for the device node
> being processed.  Not terribly elegant, but it seems worth it to get
> rid of the duplicated code (and bugs).

Good idea, I wholeheartedly agree.

> -static int of_finish_dynamic_node(struct device_node *node)
> +static int of_finish_dynamic_node(struct device_node *node,
> +				  unsigned long *unused1, int unused2,
> +				  int unused3, int unused4)
>  {


Is there a reason for these 4 unused fields that I am just missing?





More information about the Linuxppc64-dev mailing list