[PATCH] PPC/PPC64: Introduce CPU_HAS_FEATURE() macro

Pekka Enberg penberg at gmail.com
Fri Feb 4 19:17:48 EST 2005


On Fri, 4 Feb 2005 01:22:54 -0600, Olof Johansson <olof at austin.ibm.com> wrote:
> +#define CPU_HAS_FEATURE(x)     (cur_cpu_spec->cpu_features & CPU_FTR_##x)
> +

Please drop the CPU_FTR_##x macro magic as it makes grepping more
complicated. If the enum names are too long, just do s/CPU_FTR_/CPU_/g
or something similar. Also, could you please make this a static inline


More information about the Linuxppc64-dev mailing list