Booting Imac G5

Benjamin Herrenschmidt benh at
Mon Nov 22 22:16:18 EST 2004

> I tried to do mb() at the start of do_cmd() and after the cmd_done call.
> Then, when reading the RTC, I read all zeroes but the first byte which
> is 0x81. The cmd byte isn't modified, when I should read the command ack
> which is the complement of the requested command (even if I don't check
> it, for now).
> I tried to add a call to flush_dcache_phys_range, then I got the same
> result.
> But using flush_inval_dcache_phys_range (yes the name is quite
> strange....), with or without mb(), then it works.

Ok, that seem to indicate that indeed, that crap isn't cache
coherent ... I wonder how they actually access the memory from the
SMU... maybe i2c commands to U3...

> I'm not sure it'll eat all PMU commands, but it sure can treat some...

Probably not all, I'm not even sure Apple themselves still knows what
all PMU commands do :) The PMU is a mess that evolved from the original
one that was in the very first Mac Portable !

> All right !
> But I think I reached my first goal: I got a usable and stable machine
> with all basic features available.

Yes, that's really nice. Is rivafb working too ? I've seen somebody
submitting a patch that recently got into Linus bk fixing some issues
with the 5200

> This is a good start for the real deep needed work !

Hehe, indeed !


More information about the Linuxppc64-dev mailing list