Build Tools Problem

Eric V Van hensbergen ericvanhensbergen at
Tue Jun 1 22:21:43 EST 2004

I'll try the newer version of crosstool this morning. In answer to your
other questions, I'm running a 2.6.6 kernel and a 2.3.2-r9 glibc.

When I try to compile dynamically with crosstool I get a segmentation
fault.  Interestingly enough when I compile with crosstool and have /lib64
linked to the biarch /lib64 - it seems to work.


Dan Kegel <dank at>
Sent by: owner-linuxppc64-dev at
06/01/04 12:22 AM

Dan Kegel <dank at>
Eric V Van hensbergen/Austin/IBM at IBMUS, PPC64 External List
<linuxppc64-dev at>
Re: Build Tools Problem

Dan Kegel wrote:
> Eric V Van hensbergen wrote:
>> Just went through the exercise of the re-building my tools environment
>> based on the instructions from
>> Tried the crosstool route first, but could only build staticly-linked
>> applications with it.
> That sounds annoying.  What happened when you tried to
> build dynamically-linked apps?

Oh, also, points to an out-of-date
copy of crosstool.  The latest snapshot is

And can I ask which kernel and glibc your target system is running?
- Dan


** Sent via the linuxppc64-dev mail list. See

More information about the Linuxppc64-dev mailing list