problem building 64-bit gcc

Hollis Blanchard hollisb at
Fri Apr 30 00:35:06 EST 2004

On Apr 28, 2004, at 11:28 PM, Dan Kegel wrote:
> Yup.  That's why I wrote (and more or less maintain) crosstool.
> seems to build
> gcc-3.4.0/glibc-2.3.2 powerpc64 ok finally.

That's great news, I didn't know crosstool worked for ppc64. I know
that Janis Johnson has been writing her own crosstool-based scripts for
ppc64 at ... maybe you two
should chat. :)

> Say, could somebody here give it a try?  Here's how:
> wget
> tar -xzvf crosstool-0.28-rc8.tar.gz
> cd crosstool-0.28-rc8
> lynx doc/crosstool-howto.html
> sudo mkdir /opt/crosstool
> sudo chown $USER /opt/crosstool
> sh

There is no, but there is that seems
to be 64-bit.

Anyways I ran that and shortly afterwards I get this:
+ cat patch9585.log
patching file gas/read.c
+ egrep -q '^No file to patch.  Skipping patch.|^Hunk .* FAILED at'
+ rm -f patch9585.log
+ test -f
+ patch -g0 --fuzz=1 -p1 -f
+ cat patch9585.log
patching file bfd/elf32-sh.c
Hunk #1 FAILED at 6497.
1 out of 1 hunk FAILED -- saving rejects to file bfd/elf32-sh.c.rej
+ abort 'patch
sh-relocs.patch failed'

Hollis Blanchard
IBM Linux Technology Center

** Sent via the linuxppc64-dev mail list. See

More information about the Linuxppc64-dev mailing list