[PATCH] php_phy_location.patch -- please review

linas at austin.ibm.com linas at austin.ibm.com
Tue Apr 13 04:49:26 EST 2004

On Sat, Apr 10, 2004 at 09:46:59AM -0700, Greg KH wrote:
> On Fri, Apr 09, 2004 at 10:52:53PM -0500, Linda Xie wrote:
> >
> > pci_hotplug_core.c -- add  "phy_location" attribute for each php slot.
> Wait, no.  Why not just add the file for your driver alone, as it's the
> only one wanting it.  Don't modify the core for this.

OK, I'm confused: so, stupid question of the day:

There was a udev thread in March called
"Geographic naming of devices using Udev"
which I pretty much ignored.

So my stoopid, unrealistic question is "couldn't that framework
be applied for this?"


p.s. I really liked the idea of calling it "geo_location" instead
of "phy_location" since "phy" already tends to mean other things
when used in kernel sources, it already has a lot of baggage.
On the other hand, 'geo' is fresh and sparkly and has a nice
overtone of "the physical location of something".

** Sent via the linuxppc64-dev mail list. See http://lists.linuxppc.org/

More information about the Linuxppc64-dev mailing list