Xilinx LLTEMAC driver issues

Magnus Hjorth mh at omnisys.se
Sat Mar 29 23:54:15 EST 2008


I'm having some networking troubles with the Xilinx LLTEMAC driver from the
Xilinx Linux git tree (powerpc arch) on an ML403 board. EDK9.2SP2,
xps_ll_temac v1.00.b 

The weird thing is, that it sort of half works. It successfully makes a DHCP
request and gets its IP address. I tried setting up a tftpd server, and I can
see UDP requests coming in but the response doesn't seem to come out. I also
tried running a TCP server on the board, and it can see and accept incoming
connections but after that no data seems to get through. I can ping out and
get around 40% packet loss.

Looking at /proc/interrupts, I can see both TxDma interrupts and RxDma
interrupts. No eth0 interrupts but that seems to be OK judging by the driver
source comments. Ifconfig shows no collistions, no dropped packets, no errors,
so the system seems to think that everything is OK. 

Clues anyone? I'm starting to run out of ideas...

Best regards,


Magnus Hjorth, M.Sc.
Omnisys Instruments AB
Gruvgatan 8
SE-421 30  Västra Frölunda, SWEDEN
Phone: +46 31 734 34 09
Fax: +46 31 734 34 29

More information about the Linuxppc-embedded mailing list