Failure of request_irq() for MPC8313 using arch=powerpc

Duy-Ky Nguyen duykynguyen at
Wed Jul 23 11:54:50 EST 2008

Hello Scott,

I forgot to mention that I have less error if I use the existing device node 
"spi" in the DTS file

# Start of error capture

Got device node from device tree
Got Virtual IRQ
PPC : interrupt hook failed (-22)

# End of capture

So it's able to access the device node and to map "virq" while I had total 
failure in using "gpio" I put into DTS

I must make mistake in creating the node "gpio" in the DTS file

I'm using FreeScale Eva board MPC8313ERDB



----- Original Message ----- 
From: "Scott Wood" <scottwood at>
To: "Duy-Ky Nguyen" <duykynguyen at>
Cc: "Liu Dave" <DaveLiu at>; <linuxppc-embedded at>
Sent: Tuesday, July 22, 2008 10:55 AM
Subject: Re: Failure of request_irq() for MPC8313 using arch=powerpc

> On Tue, Jul 15, 2008 at 08:43:59PM -0700, Duy-Ky Nguyen wrote:
>> Hi Dave,
>> I've just tried it and it failed.
> Could you elaborate on exactly what you tried?  Did you pass the GPIO 
> device
> tree node?
>> Before I had tried using the function
>> int virq = of_irq_to_resource(GPIO_IRQ, 0, NULL);
>> and it failed the same way
> The first argument of of_irq_to_resource is a device node pointer, not an
> IRQ number.  Surely the compiler warned you about this.
> -Scott

More information about the Linuxppc-embedded mailing list