Linux boot on a ppc 405

Ricardo Ayres Severo severo.ricardo at
Tue Jan 29 09:53:19 EST 2008


my output is the following:

loaded at:     00400000 004E919C

board data at: 00000000 0000007C

relocated to:  00404040 004040BC

zimage at:     00404E2C 004E620A

avail ram:     004EA000 8DA05119

Linux/PPC load: console=ttyUL0,9600

Uncompressing Linux...done.

Now booting the kernel

nothing shows up next.
I tried to look at __log_buf but the debugger doesn't recognize it.
The debugger only knows the code of the part that boots the kernel.
I also tried setting ttyUL0 and ttyS0 for the linux console.
Any ideas of how I can get the real position of __log_buf?


On Jan 27, 2008 7:15 PM, Grant Likely <grant.likely at> wrote:
> On 1/27/08, Ricardo Severo <severo.ricardo at> wrote:
> > Hi all,
> >
> > I am working with a Xilinx Virtex II Pro  evaluation board, wich has two
> > PowerPC 405 and I'm trying to boot a vanilla linux kernel
> > Until now I've manged to make it uncompress the kernel, but it doesn't boot.
> > My question is how the initial execution (the one who uncompresses the
> > kernel image) transfers the processor to the kernel itself. I've looked
> > in the arch/ppc/boot/simple/relocate.S code and it jumps to the position
> > 0x0 after uncompressing, is it right? The kernel is uncompressed at that
> > position?
> Post your output log please.
> If your getting a message that the kernel is uncompressing, but you
> don't have any output beyond that then most likely your console is not
> setup correctly.  If you've got a debugger, look at memory at the
> __log_buf location to see if there are any boot logs there.
> Cheers,
> g.
> --
> Grant Likely, B.Sc., P.Eng.
> Secret Lab Technologies Ltd.

Ricardo Ayres Severo <severo.ricardo at>

More information about the Linuxppc-embedded mailing list