Load Kernel 2.6 using U-boot on ML403

Grant Likely grant.likely at secretlab.ca
Mon Jan 28 08:13:27 EST 2008

On 1/27/08, Yedu Jathavedan <yeduj at ece.pdx.edu> wrote:
> 1)Downloaded(sourceforge.net) & compiled the U-boot 1.1.6 files to get
> u-boot, u-boot.srec & u-boot.bin (I didn't find ml403 board config for the
> uboot. So used ml300_config).

U-boot 1.1.6 is ancient.  The u-boot project has moved off of
sourceforge to denx.de

> After this, I tried to convert the u-boot (README says that this is an ELF
> file) into an ace file. But, it gave me the error saying unable to read elf
> file. Is it because ML403 board is not supported or is it possible that the
> u-boot image that I created is corrupted?

I don't know; but personally I don't weld u-boot into an ace file. I
use a 1st stage bootloader to load the u-boot image off the cf card
(but unfortunately I'm not able to post that loader at this time).
Try again with a recent u-boot version.

> 2) Since generating ace files failed, I tried to search the net for an
> u-boot ace file that could run on ML403 & found it at
> I copied this ace file (u-boot-ml403.ace) along with the kernel 2.6 image
> (uImage) onto my CF card & booted the board. After loading the kernel, it
> fails to read the correct root device. I tried changing the "bootargs" env
> variable root = /dev/xsysace/disc0/part2 rw to root = /dev/xsysace2 rw &
> root = /dev/xsda2 rw.
> But, it failed in both cases. (There was a previous post on Problem2 a year
> ago & he solved it by giving root =/dev/xsysace2)

Looking at your bootlog, it doesn't look like you've got the systemace
driver built into the kernel.


Grant Likely, B.Sc., P.Eng.
Secret Lab Technologies Ltd.

More information about the Linuxppc-embedded mailing list