i2c device for a linux 2.6 in XUPV2P

greenlean jmgomez at atc.ugr.es
Wed Jan 16 23:43:05 EST 2008

Hi Josep,

I have read this post in linuxppc-embedded and you said that you're running
linux 2.6 in the XUPV2P. I'm beginning in this world (fpga and linux) and
nothing is running. I'm trying to boot kernel 2.6 on that board, but it is
resisting me. I have successfully booted it up on the ML403, but all my
attempts in the XUPV2P are crashing, maybe you could help me.

My problem is that I can't see anything in the minicom console when I
download the kernel. I build the kernel succesfully, using both UART IP
cores (UARTLite and UART16550) but in both cases there is no prompt in
minicom. I start with the TestApp generated by EDK and both MemTest and
PeripheralTest are running fine. But then when I do dow zImage, there is no

I think I'm using correctly the drivers, when I use UARTLite I configure the
boud rate at arch/ppc/boot/common/ns16550.c and I configure the kernel with:
   * initial command string console=ttyUL0,<baudrate> 
   *  and in Device Drivers/Character Devices/Serial Drivers I choose Xilinx
uartlite serial port to include in the kernel and Support for console on
Xilinx UartLite serial port.

and when I use the UART16550 I configure it 
   * initial command string console=ttyS0,<baudrate> 
   *  and in Device Drivers/Character Devices/Serial Drivers I choose Xilinx
8250/16550 and compatible support and console on 8250/16550 and compatible
serial port

I think that's the correct configuration,I read it in this list and in some
application notes from Xilinx which isn't very well.

By the other side I'm overwriting the xparameter_ml300.h file of the kernel
with the one generated by EDK 9.1i SP2, I'm using only this file from the
bsp generated by EDK.

I'm using the kernel from xilinx git and I've tried the one from secretlab,
but not the same as you, I'm using the (linux-2.6-virtex). I don't know how
to download or change to the branch "virtex-for-2.6.24" that you're using
(I'm new to git too, some help will be welcome).

Thanks I really need some guide for the process. If you know about any patch
or which is the problem I'm suffering please tell me.

Josep Maria Batlle wrote:
> Hi all,
> I have booted up linux 2.6 on Xilinx XUPV2P (using the base of ml300
> config
> file).
> Now I am trying to use the i2c in the user-space. First of all: is it
> possible?
> My first attempts have not worked. I have made this:
> 1) I enable "I2C Support" and "I2C device interface" in the kernel
> recompilation.
> 2) I added the "i2c-0" device in /dev (# mknod i2c-0 c 89 0)
> 3) then I run a simple program to open the device (provided by the
> "dev-interface" file of i2c kernel documentation) that returns this errno
> message: "No such device".
> I have tried to use the device number 1, 2, 3, 4 but these have not
> worked.
> I have tried to use the device "i2cn" but not worked. I have tried to use
> all the BSP's from the EDK (7.1i) and then only the "xparameters_ml300.h"
> in
> the compilation. After all of this, now I am modifying the RFS for
> "mdev"...
> Somebody can tell me what I am doing wrong if this use is possible?
> I use the kernel tree "virtex-for-2.6.24" from SecretLab and Busybox
> 1.7.2.
> Thanks.
> _______________________________________________
> Linuxppc-embedded mailing list
> Linuxppc-embedded at ozlabs.org
> https://ozlabs.org/mailman/listinfo/linuxppc-embedded

View this message in context: http://www.nabble.com/i2c-device-for-a-linux-2.6-in-XUPV2P-tp14491409p14879785.html
Sent from the linuxppc-embedded mailing list archive at Nabble.com.

More information about the Linuxppc-embedded mailing list