i2c device for a linux 2.6 in XUPV2P

Stephen Neuendorffer stephen.neuendorffer at xilinx.com
Thu Jan 10 04:52:18 EST 2008

Yes, it should be possible, however I don't believe the Linux adapter
for the i2c driver has been updated for current 2.6 kernel versions.
It's not currently on git.xilinx.com, and apparently the i2c subsystem
has changed significantly since the adapter was written, so it's not a
straightforward update.

If all you want to do is some simple configuration, then bitbanging the
i2c is straightforward.  I'll send you a driver that I cooked up at one
point in a separate email.


> -----Original Message-----
> From: linuxppc-embedded-bounces+stephen=neuendorffer.name at ozlabs.org
> bounces+stephen=neuendorffer.name at ozlabs.org] On Behalf Of Josep Maria
> Sent: Monday, December 24, 2007 1:27 PM
> To: linuxppc-embedded at ozlabs.org
> Subject: i2c device for a linux 2.6 in XUPV2P
> Hi all,
> I have booted up linux 2.6 on Xilinx XUPV2P (using the base of ml300
config file).
> Now I am trying to use the i2c in the user-space. First of all: is it
> My first attempts have not worked. I have made this:
> 1) I enable "I2C Support" and "I2C device interface" in the kernel
> 2) I added the "i2c-0" device in /dev (# mknod i2c-0 c 89 0)
> 3) then I run a simple program to open the device (provided by the
"dev-interface" file of i2c kernel
> documentation) that returns this errno message: "No such device".
> I have tried to use the device number 1, 2, 3, 4 but these have not
worked. I have tried to use the
> device "i2cn" but not worked. I have tried to use all the BSP's from
the EDK (7.1i) and then only the
> "xparameters_ml300.h" in the compilation. After all of this, now I am
modifying the RFS for "mdev"...
> Somebody can tell me what I am doing wrong if this use is possible?
> I use the kernel tree "virtex-for-2.6.24" from SecretLab and Busybox
> Thanks.

More information about the Linuxppc-embedded mailing list