ELDK on 64-bit host

Kalle Pokki kalle.pokki at eke.fi
Thu Feb 21 04:06:29 EST 2008

On Wed, 20 Feb 2008, Ben Warren wrote:

> On Wed, Feb 20, 2008 at 10:03 AM, Kalle Pokki <kalle.pokki at eke.fi> wrote:
> > Hi,
> >
> >  I tried to copy the ELDK 4.0 installation I had to a new Core 2 Quad
> >  machine running 64-bit Ubuntu 7.10, but the new machine refuses to
> >  execute the cross compiler. Has anyone succeeded in running ELDK in
> >  this kind of environment?
> >
> Yes (at least with 64-bit Debian on a single core Xeon), but you need
> a special library on the host.  I think it's call 'ia32-libs'.  It
> should be available via aptitude.

Thanks, that was indeed the correct library to install. Now it works just 

I'm a bit surprised there wasn't really any useful search results from 
Google with obvious keywords. I was already about to install the 32-bit 
version of Ubuntu to get the compiler working again. But then, perhaps 
installing this library was obvious to everyone else :)

More information about the Linuxppc-embedded mailing list