initramfs problem - /init file

raul.moreno at raul.moreno at
Thu Feb 21 01:44:22 EST 2008

Hello everybody,

I created a tiny root filesystem, just with Busybox, that I want to use as
rootfs through initramfs (and keep it as the final root filesystem).

First of all, I probed this root filesystem using NFS to be sure it worked
and in fact, it did. Then I created an init file which is a link to
/sbin/init and I inserted the created cpio file with this filesystem in
CONFIG_INITRAMFS_SOURCE. When I boot the system up, I get the following

Failed to execute /init

Kernel panic - not syncing: No init found.  Try passing init= option to

If I also tried with an init script instead to a link to /sbin/init, but
this error happens again.
I think the kernel finds the initramfs right, because if I don't add the
init file, I get a different error:

VFS: Cannot open root device "<NULL>" or unknown-block(0,0)

Please append a correct "root=" boot option;

What is the problem with "init"?
Could anyone help me? Thanks in advance,

Raúl Moreno

***********Internet Email Confidentiality Footer*************
This email and any files transmitted with it are confidential and intended
solely for the use of the organization or individual to whom they are
addressed.  It is expressly forbidden to retransmit or copy email and/or
this  attached files without our permission .  If you are not the
addressee indicated in this message (or responsible for delivery of the
message to such person), you may not copy or deliver this message
to anyone. In such case, you should destroy this message and kindly
notify the sender by reply email. Please advise immediately if you or
your employer does not consent to Internet email for messages of this
kind.  Opinions, conclusions and other information in this message that
do not relate to the official business of my firm shall be understood as
neither given nor endorsed by it.

More information about the Linuxppc-embedded mailing list