MPC85xx and linux IDE driver

Michael Brian Willis willis at
Sat Oct 13 04:29:44 EST 2007


I am using an MPC8540 based embedded system with a Compact Flash card in
true IDE mode. The Compact Flash card is directly connected to the
MPC8540 bus without the use of a pcmcia adapter. 

The Compact Flash card is being initialized correctly using the U-boot
boot-loader and is working properly as an ide device in U-boot. However
I cannot get linux to recognize the ide device.

I have tried several different linux config options and have tried
passing kernel command line options as advised in the
Documentation/ide.txt help file. However I have not been able to get the
kernel to recognize my ide device. 

Does anybody know if I can use the generic linux ide drivers? Or will I
need to modify/write my own driver for this type of setup? 

Any help is greatly appreciated. 


Michael Willis
Applied Research Labs - University of Texas
willis  <at>

More information about the Linuxppc-embedded mailing list