mpc8270 & Intel 82551ER on

Nicholas Hickman nhickman at
Tue Jul 3 04:41:13 EST 2007


With the help of some others I have finally figured it out.  I took a
step back and read the manual over and over along with debugging my
U-boot until it worked.  My issue there was with the SIUMCR. Since I now
had that working in U-boot I moved on to the kernel where I found that I
was redefining the SIUMCR here:

approx line 248
#elif defined CONFIG_PQ2FADS || MYBOARD
         * Setting required to enable IRQ1-IRQ7 (SIUMCR [DPPC]),
         * and local bus for PCI (SIUMCR [LBPC]).
        immap->im_siu_conf.siu_82xx.sc_siumcr =

I was entering this routine since I was basing my config off of the
PQ2FADS board.  I removed my board definition from the elif and
everything seems to be working fine.

Good luck!


-----Original Message-----
From: Pradyumna Sampath [mailto:pradyumna.sampath at] 
Sent: Friday, June 29, 2007 4:12 AM
To: Nicholas Hickman
Cc: linuxppc-embedded at
Subject: Re: mpc8270 & Intel 82551ER on

Hi Nicholas,

On 6/29/07, Nicholas Hickman <nhickman at> wrote:
> I am having trouble getting two 82551ER Ethernet controllers running 
> in Linux.  I am able to scan the PCI bus and see the devices and I was

> even able to program the EEPROM from U-boot.
> In the kernel I mapped the IRQ's through /arch/ppc/m82xx_pci.c.  I've 
> been using the e100 drive that comes with the kernel and 
> have also tried the driver directly from Intel.  Both give the same 
> results.  The PCI scan shows the correct output for how the device
should be configured.

I have the same, exact same problem. But there are some of the
differences with the setup though. I have an MPC5200B and the other
difference is that I have a 2.6.21-rt3. However its the same ethernet

I am trying out a few things here, some of them being complete guesses.
But if I hit something, I will let this list know. Anyone else had
similar issues ? Request you to please holler.


More information about the Linuxppc-embedded mailing list