i2c device for a linux 2.6 in XUPV2P

Josep Maria Batlle jepmalinux at gmail.com
Tue Dec 25 08:27:08 EST 2007

Hi all,

I have booted up linux 2.6 on Xilinx XUPV2P (using the base of ml300 config
Now I am trying to use the i2c in the user-space. First of all: is it

My first attempts have not worked. I have made this:
1) I enable "I2C Support" and "I2C device interface" in the kernel
2) I added the "i2c-0" device in /dev (# mknod i2c-0 c 89 0)
3) then I run a simple program to open the device (provided by the
"dev-interface" file of i2c kernel documentation) that returns this errno
message: "No such device".

I have tried to use the device number 1, 2, 3, 4 but these have not worked.
I have tried to use the device "i2cn" but not worked. I have tried to use
all the BSP's from the EDK (7.1i) and then only the "xparameters_ml300.h" in
the compilation. After all of this, now I am modifying the RFS for "mdev"...
Somebody can tell me what I am doing wrong if this use is possible?

I use the kernel tree "virtex-for-2.6.24" from SecretLab and Busybox 1.7.2.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ozlabs.org/pipermail/linuxppc-embedded/attachments/20071224/2b135fec/attachment.htm 

More information about the Linuxppc-embedded mailing list