Cannot login via tinylogin on sequoia

Leonid Leonid at
Tue Dec 4 07:25:42 EST 2007

I can avoid login procedure at all by replacing tinylogin call by simple
sh in inittab or by removing inittab at all:

#::askfirst:/bin/tinylogin login -f root 

I get shell prompt all right without logging. However login doesn't work
and I don't understand why. 

I tried to change password using passwd (user: root, password: root),
but login still doesn't work:

/ # passwd root
Changing password for root
Enter the new password (minimum of 5, maximum of 8 characters) Please
use a combination of upper and lower case letters and numbers.
Enter new password:
Re-enter new password:
Password changed.
/ # Dec 31 18:02:29 Sequoia passwd[38]: password for `root'
changed by user `root'

/ # login

Sequoia login: root
Login incorrect

Does somebody know a way to make tinylogin give out more detailed
iunformation? Of course, I can always debug it since I have source...



-----Original Message-----
From: at
[ at] On Behalf
Of Leonid
Sent: Friday, November 30, 2007 3:10 PM
To: linuxppc-embedded at
Subject: Cannot login via tinylogin on sequoia


I have built u-boot, kernel and filesystem using ELDK 4.1 for AMCC
PPC440EPx sequoia board. When I boot linux using NFS filesystem,
supplied with ELDK itself, I can login (usrr root, no password). However
I couldn't login while used ramdisk, built by myself or taken from AMCC
resource CD. Combinations root/root or root/nothing don't work. 

Sequoia login: root
Login incorrect

Please press Enter to activate this console. Dec 31 18:00:26 Sequoia
auth.warn login[37]: invalid password for `UNKNOWN' on `ttyS0'
Dec 31 18:00:26 Sequoia init: Process '/bin/tinylogin login
-f root' (pid 37) exited.  Scheduling it for restart.

How I can learn what user/password combination are configured and how do
I change them? This is static/etc/passwd from my SIMPLE filesystem:

ftp:*:14:50:FTP User:/


Linuxppc-embedded mailing list
Linuxppc-embedded at

More information about the Linuxppc-embedded mailing list