Slow boot with NFS, server not responding

Edward Jubenville edjubenville at
Thu Jul 27 05:55:32 EST 2006

Andrei wrote:
> Did you try using ethereal or tcpdump to see what is going on the wire?

I ran ethereal on the NFS server and on a PC connected to the same hub as
the target board highlighted the problem.  Many NFS READ REPLY messages from
the server were getting lost on their way to the target board.  The default
timeout was slow (about 1 second) so boot time was grossly extended.  The
packets were getting dropped by a Bay Networks switch.  Bypassing the switch
temporarily solved the problem, but I needed a more robust solution.

Matej wrote:
> We solved this by specifying additional kernel command line parameter:
>    nfsroot=,tcp
> which specifies that for the NFS TCP should be used instead of UDP.

I tried that, and the behavior changed only a little bit.  I would still get
the original error messages, but I would also get TCP checksum errors
reported.  I think the problematic switch was being overwhelmed.  I then
looked at other NFS mount arguments, and tried lowering read/write sizes to
fit into a single Ethernet packet.

I tried:
and that fixed the problem!

Thanks for the help!

Ed Jubenville

More information about the Linuxppc-embedded mailing list