ML403, ppc 405 crash

Wade Maxfield wmaxfield at
Tue Aug 22 07:45:15 EST 2006

  I tried it again.  This time I put updatedb in background.  I'm running an
nfs mount.  I tried doing a make to get fixdep built while updatedb was
running in background:

bash-2.05b# eth0: Could not transmit buffer.
eth0: Could not transmit buffer.
eth0: Could not transmit buffer.
protocol 0800 is buggy, dev eth0
Oops: kernel access of bad area, sig: 11 [#1]
NIP: C01C2744 LR: C01C276C SP: C2E25C90 REGS: c2e25be0 TRAP: 0300    Not
MSR: 00021030 EE: 0 PR: 0 FP: 0 ME: 1 IR/DR: 11
DAR: 00000004, DSISR: 00800000
TASK = c2cf6170[1027] 'frcode' THREAD: c2e24000
Last syscall: 234
GPR00: 00021030 C2E25C90 C2CF6170 C3BF4480 C03CC380 C3190810 000005E8
GPR08: 00000003 00000000 00000008 00000000 35005599 10018E04 100C3248
GPR16: C00DB1CC C02DCE08 00000002 00000004 C2E25DF8 C02E0000 C02A0000
GPR24: 000254C8 C02ED728 C02ED750 00000040 00000000 C03A8800 00000001
NIP [c01c2744] process_backlog+0x80/0x1a0
LR [c01c276c] process_backlog+0xa8/0x1a0
Call trace:
 [c01c2908] net_rx_action+0xa4/0x1cc
 [c001bef4] ___do_softirq+0x7c/0x114
 [c001bfc4] __do_softirq+0x38/0x64
 [c001c080] do_softirq+0x58/0x60
 [c001c0fc] local_bh_enable+0x74/0x80
 [c021f328] __rpc_execute+0x2c0/0x3d4
 [c00dab38] nfs_execute_write+0x3c/0x60
 [c00db084] nfs_flush_list+0x528/0x550
 [c00db1b8] nfs_flush_inode+0x10c/0x120
 [c00dbc44] nfs_sync_inode+0x54/0xb4
 [c00d1660] nfs_file_flush+0x7c/0xf0
 [c005bbbc] filp_close+0xa0/0xd8
 [c00182f0] put_files_struct+0xb0/0x130
 [c0018ab8] do_exit+0x1c0/0xda8
 [c0019714] do_group_exit+0x38/0xf8
Kernel panic - not syncing: Aiee, killing interrupt handler!
 <0>Rebooting in 180 seconds..
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Linuxppc-embedded mailing list