USB flashdrive on Motorola MPC5200 (IceCube) board, linux ker nel 2.4.25 (DENX drop)

Furxhi, Orges Orges.Furxhi at
Tue Aug 1 02:35:23 EST 2006


Thanks for responding,

> > usb.c: USB device not accepting new address=2 (error=-110)
> We had that problem on a few of our boards as well.
> For the old Icecube exists the possibility to mount two different USB
> transceivers, one of them the ISP1107DH, the other one the
> P11PAPW. Which one of the two is mounted on your board?

The Icecube board has the USBP11A transceiver and our custom board has 	the
ISP1105 (this has a problem with low speed devices according to PHILIPS).  

> On our own boards we had problems with low speed devices and the
> ISP1107, the other transceiver that Freescale used worked
> fine. Connecting those low speed devices via a hub worked. 

We get the same message when we connect the hub itself to the USB port
Does anything need to be configured in the kernel to accept the USB hub, if
so which switch is it?

> We ended up using a Fairchild USB1T11A, the ISP1107 seemed to have a
> problem, we just didn't have luck with them. The Fairchild's are pin
> compatible, maybe you just give it a try.

I'll relay this to our hardware guys.



More information about the Linuxppc-embedded mailing list