Getty prob solved, problem with Telnetd persists

Vijay Padiyar vijay_padiyar at
Wed Feb 2 21:55:54 EST 2005

Hi all

With reference to my mail to this list yesterday, the Getty problem has been
solved. It was due to a mistake we made in writing /etc/inittab. Our
original inittab was:

ttyCPM::once:/sbin/getty -L 57600 ttyCPM

This was causing the problem described earlier. It didn't strike us that we
don't need to call the shell when we're calling getty, as it'll call the
appropriate shell on its own after user authentication. We commented out the
first ttyCPM line and now all is fine.

However, the Telnetd problem still persists. When I do a ls -l on a
directory with several contents, the remote telnet terminal gets _stuck_ and
there's no way to recover except to either close the telnet terminal window
or kill the shell application on the target running telnetd.

What could the problem be? Please advise.

I would also like to point out a problem with BusyBox 1.00. I have enabled
the DEVPTS file system in Linux and have enabled support for it in BusyBox.
This means that CONFIG_FEATURE_DEVPTS is enabled and defined in config.h in
the include subfolder inside the BusyBox source directory. However, the
following code still doesn't get compiled:

        p = open("/dev/ptmx", 2);
        if (p > 0) {
                strcpy(line, ptsname(p));

I had to resolve the issue by explicitly including the config.h file from
telnetd.c, by adding the following line:

#include <config.h>

I don't know if there are similar problems with other headers that don't
take effect.

However, the problem of the terminal getting stuck still persists. Please
guide me as to what I need to change.


Vijay Padiyar

More information about the Linuxppc-embedded mailing list