Preemption patch problem

Björn Östby Bjorn.Ostby at
Thu Apr 21 20:08:42 EST 2005


I have been struggling with the famous preemption patch (from Robert Love) the past few days. Im using mpc823e 
and tried with kernels 2.4.{18,21,22,23}. The patch applies flawless and so on, but when the kernel is up and running
strange memory problems start to appear like:

_alloc_pages: 0-order allocation failed (gfp=0x1d2/0)

Right, so... It seems like a giant memory leak of some sort, cause when I run programs the kernel goes ballistic and
starts reaping processes:

"VM: Killing process <name>"

Eventually it comes down to "VM: killing init" and then it's curtains.

I know that these problems is caused by the patch since the kernel runs smooth without the patch applied.
Does anyone have a clue what to do here (beside let go of the patch)? 

Best regards,
"failure is not an option"

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Linuxppc-embedded mailing list