cpm_uart console problems?

Tsang, Chi Kit chi at artesyncp.com
Wed Apr 13 21:01:11 EST 2005


I am working on an 8260 based board and currently cannot get 
the serial (running on SMC 1) to work using the 2.6.11 kernel. 
The last message I see in my console is: "Now booting the 

I currently use NFS root for mounting the root filesystem. 
Despite not seeing any output from the serial console, the 
board does actually boot up and I can telnet in okay. Here is 
what I see in:


4: 0 CPM2 SIU Edge cpm_uart
32: 23184 CPM2 SIU Edge fenet
BAD: 793


Character devices:
1 mem
2 pty
3 ttyp
4 /dev/vc/0
4 tty
5 /dev/tty
5 /dev/console
5 /dev/ptmx
7 vcs
10 misc
13 input
128 ptm
136 pts
204 ttyCPM
254 devfs

Block devices:

There are no block devices installed.

In /dev, I see:

crw--w--w- 1 root root 204, 46 Jan 1 00:32 ttyCPM0

And when I do "dmesg", I see:

Serial: CPM driver $Revision: 0.01 $
ttyCPM0 at MMIO 0xf0011a80 (irq = 4) is a CPM UART

I currently do not specify the "console=ttyCPM" in my boot command 
line. Would this be an issue?

I have tried to add "console=ttyCPM" to my boot command line but in 
such cases, the kernel would fail to boot. Using some LEDs as debug, 
I tracked down the hang which seems to happen during cpm_uart_console_write.
This is as far as I got.

I am running with devfs enabled in the kernel. Does the cpm_uart 
driver work with devfs?

As an aside, I have ported the 2.6.5 kernel to my 8260 based board and
both ethernet (FCC 1) and serial (SMC 1) worked okay using this particular

Any suggestions/ideas would be much appreciated.


More information about the Linuxppc-embedded mailing list