Linux on Memec Virtex II Pro V4P7 Rev. 3

Jon Masters jonathan at
Mon Oct 11 08:20:08 EST 2004

Hash: SHA1

Tony Lee wrote:

| On Sat, 9 Oct 2004 20:27:15 +0100, Jon Masters <jonmasters at>
|>On Thu, 7 Oct 2004 19:53:52 -0700, Tony Lee <tony.p.lee at> wrote:
|>>The problem I saw was that I can't turn off the interrupt at all.
|>On the Memec board? really?

| No, not on Memec,  just on our own HW.

Ah ok. Like you said, it's probably tied lines probably in the hardware
definition at fault here.

| I have the memec board, but I don't have time to play on that one.

Ah ok. I have a wonderful mixture of Memec and custom board also.

| I got to debug the HW one week after I was hired.

Indeed. Fun huh.

| As far as I can tell, our linux for memec board doesn't load
| the sysace driver.

Ok if you're not using it I guess.

|>>Once I start one write command, the ISR keep coming in.


| Tell me about it.  It tooks me 3+ days to id this.

It's taken me a long time on and off to fix these kinds of problem
because of the usual case of balancing other bits and pieces.

|>Perhaps. But that's down to your hardware guys to check the error
|>output from your synthesis tool to see if this weirdly has happened.
|>Our board doesn't have lines hard tied together, if that was the
|>notion you were offering.

| I tried to synthesize chipscope into into our VP20.

It apparently doesn't work if you're using sysace inline on the same
JTAG line that you want to use for chipscope interfacing. Having said
that I've not used chipscope other than seeing a very biref demo, and I
only heard this from a third it might actually work ok.

| It is less of a priority since the sysace is working
| now for 1.5 months (without ISR).

I also have moved on to fixing other bits, bodging in a NULL ioctl in
smc91111.c to handle ethtool requests that aren't wanted, etc. Usual
case of fixing it up good enough for the current project and problem at
hand but wanting to find a better solution for next time around.

| Also, we use linux as Xilinux dev environment

We don't mostly for historical reasons, but I'm planning on moving the
development the way soon - I want this all nice and scriptable and this
just aint gonna be pretty on Windows. [OT] I just spent two hours on a
train with an MSFT employee sitting next to me...we didn't kill each
other but had a variety of interesting conversation.

|>>I try turn off the ISR on write with SYSACE register and
|>>the ppc interrupt control register.  None of them worked.

|>Did you do it as per my patch, or what?

| No, where can I find your patch?

In the list archives. It's only a quickie few lines, there's other stuff
I need to cleaup. Having mentioned that, I'm still working on the stuff
I mentioned in another thread on OpenFirmware tonight, having not got as
far as I planned this weekend. Less sleep tonight then.

|>Yes. We come up in 8 seconds to my firmware, and total boot time is
|>around 20 seconds, without any effort to make it less. That includes
|>cunning DHCP+ZeroConf scripts I wrote.

| That's about right,  We don't do DHCP, it comes up a bit faster.

I'd love to create a special interest group of Linux on Virtex II Pro
users - not really a mailing list, just a group of us who use it and are
willing to share experiences with eachother and perhaps newcomers as the
documentation for all of this is shockingly absent :-).


Version: GnuPG v1.2.2 (GNU/Linux)
Comment: Using GnuPG with Thunderbird -


More information about the Linuxppc-embedded mailing list