Anyone using uClibc on a 405GP platform?

Joakim Tjernlund joakim.tjernlund at
Tue Feb 24 23:21:44 EST 2004

> On Tue, Feb 24 2004, Torben Mathiasen wrote:
> >
> > Hi,
> >
> > Does anyone successfully use uClibc on a 405GP platform? I
> tried compiling
> > uClibc but all my dynamic apps just segfault. Its the
> shared library loader
> > that segfaults immediately after execve(). I tried both a
> recent 2.4 and 2.6
> > kernel with the same result. Also using latest 0.9.26 uClibc.
> >
> > Has anyone gotten this to work?
> >
> Funny, I got this to work. I was under the assumption that
> one should be able
> to execute the library loader directly, which has never
> worked for me on
> powerpc. But a dynamic linked application seems to be working
> now. Both those
> I compiled myself and the ones I got from the root_fs_powerpc fs.

hmm, not sure about executing ldso directly, you may have better luck asking
about that on the uClibc list.

ldso is however somewhat broken. Lots of stuff/fixes has been added
since the last release.

** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list