serial reset?

Hollis Blanchard hollis at
Thu Nov 7 04:13:08 EST 2002

Hi, I'm working on sleep on the 405LP. In one mode the chip is powered
down and all state must be saved/restored by software.

My current problem is with the UART (and I'm using serial console only,
so it's problem). When I wake up, I can type commands to my shell and
see them echoed correctly. However the result of those commands is
garbled, like so:
    1  tm[lc ;u;v  43m
Sometimes I get the message "ttyS: 1 input overrun(s)". Return
characters come through as spaces.

I've tried to save/restore the UART registers just like all the others.
Unfortunately FCR is write-only, and my attempts have just resulted in
no serial activity at all.

I've also tried the unregister_serial/register_serial calls to the
serial driver (intended for PCMCIA). I can't see how those ever worked
-- unregister_serial doesn't reset state->count, which causes
register_serial to complain the device is already open. When I hack the
driver though, I get the same result though: dead serial.

This is a 2.4.17 kernel. Can you think of anything situation that would
allow correct character echo but not output? I don't mind going through
a full serial initialization if necessary, but it doesn't look like the
driver was mutated *ahem* written with this in mind...


** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list