Another OCP enet patch

Armin Kuster akuster at mvista.com
Thu May 30 02:01:59 EST 2002


Dan Malek wrote:

> We can't change the PCI names, so I just suggested we change the names to
> consistent_sync(), define those in io.h (so non-PCI systems don't have to
> include pci header files just to get a flag name), and put a big comment
> around the flag definitions that they have to match the PCI_ names.

Why not put the flag definition in a /linux/dma.h and include that in
/linux/pci.h.  Have the pci flags be defined as the ones in dma.h.  That
way it's obvious where the orginal defines are and easier to maintain. :)


dma.h
/* This defines the direction arg to the DMA mapping routines. */
#define DMA_BIDIRECTIONAL	0
#define DMA_TODEVICE		1
#define DMA_FROMDEVICE		2
#define DMA_NONE		3

pci.h
/* This defines are defined in linux/dma.h */
#define PCI_DMA_BIDIRECTIONAL	DMA_BIDIRECTIONAL
#define PCI_DMA_TODEVICE	DMA_TODEVICE
#define PCI_DMA_FROMDEVICE	DMA_FROMDEVICE
#define PCI_DMA_NONE		DMA_NONE


>
>
>     -- Dan
>
>
>
>
Armin


** Sent via the linuxppc-embedded mail list. See http://lists.linuxppc.org/





More information about the Linuxppc-embedded mailing list