Jon-Erling Dahl jon-erling.dahl at
Sat Mar 2 20:53:58 EST 2002

> >I'm having problems getting libraryopt doing something.
> >(
> >Is there anybody out there that have used this utility
> >successfully?
> There was a thread about this topic, with detailed descriptions.
> Maybe this
> link helps you:
> I have not managed to use libraryopt (I tried not very hard), but was
> successful with
> If you are using hardhat linux, libraryopt is recommended.

I managed to get it working. The libopt program seems to look
for the build script in the wrong directory (at least according
to my setup ;). Changing that, and the build script executed.

However, the build script is supposed to get all needed object
files as input. My build script didn't get any object files at
all and I think its because of this:

I have an application 'myapp' that depends on a shared library
'mylib'. 'mylib' in turn depends on 'somelib', like this:

myapp -> mylib -> somelib -> libc, libstdc++, etc

What I tried was to create an optimizer for somelib. But since
myapp doesn't depend on somelib directly, it seems that libopt
doesn't think any of the object files in 'somelib' is needed,
and hence no object files as input to the build script.
Is this correct? Does libopt only work when an application is
linked directly against the lib you're trying to optimize?
Am I completely missing something here?
I built an optimizer for 'mylib', and it worked correctly...

Are there any other utilities for solving this problem? Does solve it better?


** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list