Remote Multithread debugging problems

Wolfgang Denk wd at
Wed Aug 21 00:58:14 EST 2002

Dear Owen,

in message <20020820144703.16442.qmail at> you wrote:
> I`m trying to debug a multi-threaded application using
> gdbserver on the remote/target side and I`m having
> some problems, the output I got is depicted below:

I'm not surprised. This is broken in most versions of GDB / gdbserver
floating around.

> I`m using gdbserver5.2.1 (I tried the one from HHL-2.0
> Journeyman and didn`t worked too) compiled by myself
> using Mvista HHL 2.0 tools and gdb 5.2.1 on my i386.
> Am I doing something wrong or remote thread debugging
> is not supported by gdb? I have read something about

Let's say the support is incomplete :-)

> problems with multi-thread application debugging but I
> thought that it may be OK at this time...
> Could someone explain to me what`s happening?

Check out our ELDK  (see;  it  contains  an
extended  /  bug  fixed  version  of  GDB  / gdbserver; remote target
debugging of MT applications was one of the areas where we spend some

If you're just looking for the patches: these can be found on our FTP
server; the README including description of the test procedure is at

Hope this helps.

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: wd at
That's the thing about people who think  they  hate  computers.  What
they really hate is lousy programmers.
- Larry Niven and Jerry Pournelle in "Oath of Fealty"

** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list