init is running (didn't trigger the wait queue panic)

Dan Malek dan at
Wed Jun 14 13:33:35 EST 2000

diekema_jon wrote:

>         I tried running init again with Linux 2.4.0-test1-ac10
>         (through changeset 00/06/12 18:04:09-04:00
>         dmalek at, and I was surprised to find that it
>         worked.  Previously, init was triggering a wait queue panic in the
>         scheduler.

I forget that if you are not on the BitKeeper mailing list you don't
see the updates people make.  Wolfgang sent me a stack backtrace that
pointed right to a problem in the uart driver with wait queues.  They
were not initialized properly (actually, not at all :-), so you would
get erratic behavior for any type of uart open/close.  This was fixed
a couple of days ago.

This affects both 8xx and 8260, so suck down the latest 2.4.0 sources
and give them a test.

Now, I will do some 8260 updates, hopefully to fix that irritating
Ethernet bug and the timer stuff you sent me.  I'll try to be better
about posting update message to this list (if people want that info).

	-- Dan

** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list